Modern PC Windows XP Unreal Install Guide.

POST PLAYING SETTINGS AND SUGGESTIONS HERE
Post Reply
User avatar
IceCoffee
FOD
FOD
Posts: 2
Joined: Wed Nov 08, 2006 5:42 pm

Modern PC Windows XP Unreal Install Guide.

Post by IceCoffee » Wed Oct 24, 2007 8:23 pm

Modern PC windows XP Unreal Install Guide.

Being a long time unreal player and having just built a new PC,I ran across some problems Getting Unreal to run playable on my new PC.
After several days of searching and alot of frustration,I found workarounds that work for me.I wrote this guide in the hopes that it will help others get Unreal or UnrealGold playable on a newer computer running Windows XP.More players=better game!


My current system specs:
Intel core 2 Duo dual processor at 2.6Ghz
2 Gigabytes of DDR2-667mhz memory
Gigabyte p35 chipset motherboard with integrated sound
Nvidia 7950GT 256MB graphics card.
Windows XP Service Pack 2 fully updated

I will start by describing the problems I was having with Unreal.

First Unreals speed,framerate, and animations looked erratic and choppy.Speeding up super fast and slowing down to a pause.I tried to play some single player and decided that there was not enough Dramamine in the world that would keep me from getting motion sick from how this game was being rendered.

Second the mouse look was acting really strange.Sometimes(1 out of 3 movements of the mouse) the slightest movement would spin me 180-360 degrees around no matter what the sensitivity was set to.Making it near impossible to target anything.Also making it a chore just to move around normally.

Next I will list some of the things I attempted to do,but did NOT work for me.I am listing these because what did not work for me may work for others.

Changing Graphics drivers to newer and older versions(did nothing for me)
Running unreal in windows 95 or 98 compatibility mode(no difference)
Turning on V-sync in the video drivers and the unreal.ini(no difference)
Adjusting windows mouse properties.(no difference)
changing monitor refresh rate(did nothing)
tried different patches of unreal:
Unreal gold 226b(no difference)
unreal 224(only worked in software mode)
unreal 225(would not render menus in D3D mode, open gl crashed)
unreal 226(no difference)
unpatched unreal(no difference)

So I went searching the net for hours and hours and found some posts buried on the Old Unreal forums about this problem and they offered several solutions.
The ones I list here worked for me,and I hope they work for anyone else having these problems also.

The alternative solutions won't be listed here because I have not tried them.
They involve editing windows registry or compiling source code,neither look very easy and could ruin the game install or windows.

Begin by installing Unreal or Unreal Gold and patching it with the proper official patch.
I have tested patch 224v on the original unreal and unreal gold 226b(my copy of Unreal Gold did not need a patch it was already 226b on the disk).
you can download the official patches from here:

http://www.oldunreal.com/officialpatches.html

The first issue with erratic Speed, framerates, and animations was the easiest one to solve.It was due to unreal not liking Dual Core processors.You need to make unreal use ONLY 1 core of the processor.Simple fix:

1- Start unreal

2-Hit Ctrl+Alt+Delete to bring up the task manager

3-On the Applications Tab(the first one on the top left) right click on unreal
and choose the GO To Process option on the menu(the last option)

4-You should be on the process tab with unreal.exe highlighted.Right click on Unreal.exe and choose Set Affinity.

5-Uncheck one of the CPU check boxes and click ok at the bottom of the box.

6- Return to unreal and the erratic framerate and animations should now be smooth as silk.

The only problem with this method is that EVERY time you start Unreal or Unreal Gold you have to do this work around again,because everything defaults to trying to use 2 cores.

If that does not bother you then you can use this work around every time you start the game.

I decided to have Unreal or Unreal Gold automatically use only 1 processor at startup so I would not have to do the previous procedure every time I started Unreal.

This program modifies the Unreal.exe to include configuration information so that the game now always uses 1 core of the dual core processor.

NOTE: BE sure to do this AFTER installing the Old Unreal Multimedia patch!!!!

The Old Unreal Multimedia patch REPLACES the original Unreal.exe file.

To accomplish this some additional software is needed.There are several programs available on the internet that are written by third parties that do this,but I wanted something small from Microsoft that would accomplish this.After several hours of searching I found out that Microsoft had designed a command line program called ImageCfg that does just this,but is not offered for download anymore:

People talking about using it for setting programs to use one core it on the

Microsoft forums:

http://forums.microsoft.com/MSDN/ShowPo ... 3&SiteID=1
ImageCfg originally came on the Windows NT server disk:

http://www.microsoft.com/technet/archiv ... x?mfr=true

Download the utility here:(This is not my website so I make no claims to the integrity of the file.)

http://www.robpol86.com/Pages/imagecfg.php

Instructions for installation and using the program are also on the website.

After modifying Unreal.exe to use 1 processor only you can uninstall the program if you have no further need of it.
Installing and uninstalling is as simple as copying and deleting the file twice.


The Second issue with mouse movement being erratic turned out to be related to framerate.I had to install the Old Unreal Multimedia patch from the OldUnreal website and limit my framerate in the Unreal.ini file to get smooth mouse movement.

You can get the patches here:

http://www.oldunreal.com/oldunrealpatches.html

I have used the v0.2 unreal 224 and the UnrealGold patch from there and they both fixed my mouse issue in both version of the game.To limit the framerate:

1-Install the correct patch for your version of unreal.(V225 will not work because it does NOT have an updated OpenGL renderer in the patch)

2-Start unreal then close it to make sure the unreal.ini file is created.

3-Backup your unreal.ini file(default location is c:\unreal\system\unreal.ini)
Just right click on the file and hold the button down,drag the icon a little and release.Then choose copy here from the drop down menu.

4-Open your Unreal.ini file (default location is c:\unreal\system\unreal.ini)

5-Under the [Engine.Engine] heading near the top of the file,change this line:
GameRenderDevice=SoftDrv.SoftwareRenderDevice
to:
GameRenderDevice=OpenGLDrv.OpenGLRenderDevice

Do this so Unreal uses The new OpenGl driver from the patch.

6-scroll down to the section [OpenGLDrv.OpenGLRenderDevice] (or copy this line and paste it in the search box)

7-Copy and paste this section into your original unreal.ini overwriting the
original [OpenGLDrv.OpenGLRenderDevice] section.

[OpenGLDrv.OpenGLRenderDevice]
Translucency=True
VolumetricLighting=True
ShinySurfaces=True
Coronas=True
HighDetailActors=True
DetailTextures=True
TruFormMinVertices=0
TruFormTessellation=3
UseTruForm=False
ZRangeHack=False
AAFilterHint=0
NumAASamples=0
UseAA=False
RequestHighResolutionZ=True
MaskedTextureHack=False
FrameRateLimit=60
SwapInterval=-1
UseVertexProgram=False
UseCVA=False
UseMultiDrawArrays=False
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
CacheStaticMaps=False
UseTexPool=True
UseTexIdPool=True
UseSSE=True
BufferTileQuads=False
BufferClippedActorTris=True
SinglePassDetail=False
SinglePassFog=False
ColorizeDetailTextures=False
DetailClipping=False
UseDetailAlpha=True
DetailMax=0
RefreshRate=60
NoFiltering=False
NoMaskedS3TC=False
MaxAnisotropy=0
UseTNT=False
Use16BitTextures=False
UseS3TC=False
UseAlphaPalette=False
AutoGenerateMipmaps=False
UseTrilinear=False
UsePrecache=False
AlwaysMipmap=False
ShareLists=False
UsePalette=False
UseMultiTexture=True
UseBGRATextures=True
UseZTrick=False
MaxLogTextureSize=8
MinLogTextureSize=0
MaxLogVOverU=8
MaxLogUOverV=8
OneXBlending=False
GammaCorrectScreenshots=False
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
GammaOffset=0.000000
LODBias=0.000000

This section has a FrameRateLimit option.I have it set to 60 which seems to work great for me.If you want to experiment and change that to higher or lower number you can.

Also of note If you have a CRT tube monitor(like me) you can change the refresh rate that Unreal or Unreal Gold run at by editing RefreshRate=60 to a higher number.If you have a LCD monitor leave it set to 60.

WARNING: be sure your monitor supports the refresh rate you set or you will get no picture on your monitor when you start unreal!!!

I run my game at 1024x768(you can set resolution in the options menu in the game) at 100 refresh rate (60 gives me a headache).Most CRT monitors should support that setting,and the text on the screen isn't too small to read.

Another important setting worth mentioning is:

PurgeCacheDays

In the unreal.ini file.(open the file and copy and paste this into search to get there quick)
This is set to 30 by default so after you files in your cache folder become 30 days old Unreal will automatically DELETE them.
This causes problems with servers that have alot of mods on them ,because you will have to re-download all files after the files get 30 days old.This is a needless waste of game time.
Also it causes problems if you have you cache from a previous install backed up and are trying to use it with your new install.If the files are over 30 days old unreal will DELETE them on you.Set this to 0 to avoid these problems.

PurgeCacheDays=0

Now Save the Unreal.ini file.

REMINDER: if you want to use ImageCfg to automatically have unreal only use 1 core of a dual core CPU this is the time to use it.Your Unreal.exe file will have been replaced with the Old Unreal patch!!!


I hope this guide helps some people that are having problems running Unreal or Unreal Gold on Windows XP on a newer computer.

Thanks to Smirftsch for OldUnreal.com and the Old Unreal Multimedia patches.Without either Unreal would be unplayable for me.

This is by no means a comprehensive guide.I am sure there are alot of other problems people are running into trying to get Unreal running on a modern PC that I have not experienced.I hope others will add their problems and work arounds so we can get more people in the game or help people in the game have a more enjoyable experience.Thanks for reading.









User avatar
GOOGZ
FOD
FOD
Posts: 76
Joined: Tue Aug 02, 2005 12:58 am

Post by GOOGZ » Wed Oct 24, 2007 11:17 pm

hey man, much appreciated, i will try out some of these fixes,..

if they help or don't help, thanks :)
Image

User avatar
wever.nl-(DOG)-
Site Admin
Site Admin
Posts: 847
Joined: Wed Oct 06, 2004 11:42 am
Location: Netherlands
Contact:

Post by wever.nl-(DOG)- » Thu Oct 25, 2007 10:03 am

Thanks for sharing !!
--= Keep Running =--
_________________

User avatar
BlondePsycho-(DOG)-
-(DOG)-
-(DOG)-
Posts: 33
Joined: Sun Jul 11, 2004 12:45 am
Location: Tweed Ont. Canada

Post by BlondePsycho-(DOG)- » Thu Oct 25, 2007 12:31 pm

I had that problem with unreal a while ago when I was running xp.
The easiest solution for myself was to partition the drive and run 98 on it as well. this allowed me to run several programs that xp didn't like without having to go searching and downloading all sorts of stuff to make it work.
Still haven't got myBT878 capture card running correctly yet. Even on 98:(
It used to work but no longer does:( I've tried several different patches for it with no success. Mind you..the card is old and since I'm no longer running xp at all since my last reformat there is no sense going out and getting a newer card because nothing these days will run on 98.
I know it's an old program but I'm used to it and I like it.
"The devil you know is better than the devil you don't!!"
That sure seemed like a whole whck of stuff to do to get unreal to work on xp. Mark (NIDI) was running into the same problems due to service pack 2 for xp. I'm not sure how he got his unreal to work after I burned him a copy of gold.
BUT IT WORKS and he's playing again:)
woof
In ANY tower or tree overlooking YOU!!

User avatar
IceCoffee
FOD
FOD
Posts: 2
Joined: Wed Nov 08, 2006 5:42 pm

Post by IceCoffee » Thu Oct 25, 2007 2:27 pm

Thanks for sharing your work around.I would run win 98 also if it were not for manufacturers not supporting it anymore.They haven't made drivers for the hardware for the last 2 PC's I have built, so I have gotten used to windows XP.Funny thing is that my last PC had none of these problems with windows XP service pack 2 installed.Unreal ran fine.I guess changes to the drivers and the hardware are the culprits for the issues I have encountered.

The only old programs that I run these days are Unreal,Deus Ex,and System Shock 2.Everything else has been updated to windows XP compatible programs.I assume that soon I will have to start getting ready for windows Vista which I am sure will bring issues to all the programs I currently use.The only thing constant in the PC world is change.

The post may seem like alot of work to get Unreal to run, and it was to find all the information.If you sit down and do it and don't have to search the net for hours,it only takes a few minutes to do.
That is why I posted it in the hopes it will help someone having issues so they do not have to spend hours searching for work arounds.

If anyone else has different fixes for these issues that work for them or work arounds for different issues please post them.

Post Reply