Page 1 of 1

Control problem

Posted: Fri Aug 06, 2010 2:51 pm
by £éè£å-(DOG)-
Hi :)

I have a weird problem with my controls from time to time, especially when I worked much with the editor.
My normal setting is this:
Up key = forward
Down key = backward

When I enter the game my view goes straight up. When I press Up it goes up, when I press Down it goes down. Sometimes I move when pressing Up or Down, but the view keeps going up. I checked the settings in the User.ini and there is nothing wrong.
The only way to fix it, is to reboot Windows. That is really annoying 'cause I have some programs which don't like to be interrupted.
Does anyone know the reason for this fault, or a way to fix it without the need to reboot Windows?


Re: Control problem

Posted: Fri Aug 06, 2010 3:34 pm
by Oldsparky
What kind of mouse and are you using other than just windows drivers for mouse?

Re: Control problem

Posted: Fri Aug 06, 2010 4:43 pm
by £éè£å-(DOG)-
Because I play to much Unreal I often have to change my mice :lol: :lol: :lol:
You can say, a mouse I use has not a long life compared with a normal used mouse :lol:
I use standard ball mice with two buttons and a wheel. I never install drivers and use the windows driver for it. For me it's enough 'cause I need no extra functions.
First I thought the mouse is the reason, but that is not explaining the mismatch with the keys. I'm really at a loss with this problem and have no idea why it happen.
Unreal is the only application where it happens, other programs still work fine.

Re: Control problem

Posted: Fri Aug 06, 2010 5:26 pm
by Oldsparky
There is some stuff relating to mouse in UTeam but I dont think that would be the problem in this case. If its happened just with this mouse, perhaps its this mouse only or maybe even the keyboard. Some keys that you use for unreal may be just worn out. Other than that, dunno. You could uninstall keyboard and mouse and re install drivers, just in case you have a corrupted file.

Re: Control problem

Posted: Wed Aug 18, 2010 1:00 am
by Shadow
oh, this has happened to a friend of mine before. The only solution for him was to completely reinstall Unreal. I'm sure that you probably have a lot of important files, though. So I would probably try deleting the control input section of Unreal.ini and replacing it with the one from the CD.

Re: Control problem

Posted: Mon Sep 27, 2010 3:55 am
by £éè£å-(DOG)-
Hi :)

Ok, maybe I finally found a solution without the need of rebooting windows.
Was doing some work with videos and after that when entering Unreal, same problem again :evil:
( Oh, I noticed that I was moving forward and back when using the mouse. This shouldn't happen normally.)

I always thought it's the mouse causing the problem, but it seems more like the controls are messed up somehow.
Well, I experimented a little with the settings and did this:
Under Options/Customize Controls I looked for 'Look Up' and 'Look Down'
Look Up was defined with 'Delete', Look Down wasn't defined so I set it to 'Insert'

Back in the main menu I noticed that 'AlwaysMouseLook' was deactivated, weird because it's always set to True. So I activated it again and entered the game and voila, all worked normal again.
Maybe AlwaysMouseLook was deactivated when I redefined Look Down.

I never use the keys for looking up or down and maybe just a redefine of these two functions can solve the problem. If your controls are messed up again just try to exchange the two functions:
Look Up = Insert and Look Down = Delete or vice versa. Activate AlwaysMouseLook again and enter the game. This really seems to work and I do not need to reboot windows :D

Re: Control problem

Posted: Sat Oct 02, 2010 8:00 am
by £éè£å-(DOG)-
Ok, had the same problem again earlier. Entered a map and my view kept going up. I went to Options/CustomizeControls and redefined 'LookUp' and 'LookDown' like I wrote in last post. Closed Options again and problem was fixed. I even didn't need to restart Unreal :D

When I think how often I had to reboot Windows to fix it, I just could cry :lol: :lol: :lol:

Re: Control problem

Posted: Sat Oct 02, 2010 9:20 pm
by UnrealStunner
This is what I was doing My best to Explain to you in the game Yesterday.

Blinds that I make sure I deleted
Key "=" LookUp
Key "Delete" ViewUp

They are the two I have had things go crazy over.

Re: Control problem

Posted: Sun Oct 03, 2010 5:55 am
by £éè£å-(DOG)-

sorry I'm always a little slow online :lol:
yup that solve the problem. I always thought it was somehow Unreal related, but it has nothing to do with it. Only the key defined for LookUp is sometimes messed up and when you start Unreal you have a problem :lol: :lol: :lol:

Edit: Noticed today it's even more simple. Just hit the key you have defined for 'LookUp' once and all works well again :lol: :lol: :lol: